Back to overview
Degraded
Degraded service
Mar 17 at 06:26pm CET
Affected services
api.novem.io/v1
User e-mail
Resolved
Mar 17 at 09:25pm CET
Service has been restored, but we are awaiting confirmation from our service provider that the incident has been resolved. We will continue to monitor the situation.
Affected services
api.novem.io/v1
User e-mail
Created
Mar 17 at 06:26pm CET
We are currently experiencing issues with our mail services due to an internal node being down. This is caused by ongoing issues with our service provider. We are monitoring the situation and will provide updates as they become available. Thank you for your patience.
Affected services
api.novem.io/v1