System upgrades
Resolved
Apr 22, 2026 at 7:18pm UTC
Maintenance ended
Affected services
Updated
Apr 22, 2026 at 7:18pm UTC
All services have now been successfully upgraded and functionality should be back to normal.
Affected services
Created
Apr 22, 2026 at 7:15pm UTC
We upgrade all production servers for novem.io to ensure systems are up to date with the latest operating system versions and security patches.
Systems will experience intermittent downtime as services are restarted.
Affected services