System upgrades
Resolved
May 10, 2026 at 6:49pm UTC
Maintenance ended
Affected services
Updated
May 10, 2026 at 6:49pm UTC
All services have now been successfully upgraded and functionality should be back to normal.
Affected services
Created
May 10, 2026 at 5:50pm UTC
We upgrade all production servers for novem.io to ensure systems are up to date with the latest operating system versions and security patches.
Systems will experience intermittent downtime as services are restarted.
Affected services