Back to overview
Resolved
Job execution issues
Jul 2, 2026 at 8:42am UTC
Affected services
api.novem.io/v1
Job e-mails
Resolved
Jul 2, 2026 at 9:50am UTC
All services are back to normal.
Affected services
Updated
Jul 2, 2026 at 8:57am UTC
We're still experiencing some issues with responses to jobs triggered by e-mail, but job execution services are functional.
Affected services
Created
Jul 2, 2026 at 8:42am UTC
We are experiencing issues with jobs triggering and execution. The issue is under investigation.
Affected services